[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [libvirt] libvirtd hang while saving domain ??



>   One thing you can do first is upgrade to libvirt-0.6.0-1.fc9 package

> I just built in kodji, also install the debuginfo package, and if you

> can reproduce the hang, then attach gdb to the libvirtd process to get

> hint of where it's coming from.

 

Hi,

 

** missing rpm-dependency ?

[root kvm11 ~/libvirt/0.6.0-1]$ rpm -i libvirt-debuginfo-0.6.0-1.fc9.x86_64.rpm

warning: libvirt-debuginfo-0.6.0-1.fc9.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID de95bc1f

error: Failed dependencies:

        libvirtmod.so()(64bit) is needed by libvirt-debuginfo-0.6.0-1.fc9.x86_64

 

This missing file depends on libvirt-python - maybe you have adjust the rpm-spec for this (-:

 

** debugging

I’m not familiar with this debugging..

 

[root kvm11 /usr/lib/debug/usr/sbin]$ rpm -qa |grep libvirt

libvirt-python-0.6.0-1.fc9.x86_64

libvirt-debuginfo-0.6.0-1.fc9.x86_64

libvirt-0.6.0-1.fc9.x86_64

 

[root kvm11 /usr/lib/debug/usr/sbin]$ /usr/lib/debug/usr/sbin/libvirtd.debug

-bash: /usr/lib/debug/usr/sbin/libvirtd.debug: : bad ELF interpreter: No such file or directory

 

It’s a x86_64 bit fc9-system.

 

[root kvm11 /usr/lib/debug/usr/sbin]$ rpm -qa |grep elf

elfutils-libelf-0.137-3.fc9.x86_64

elfutils-0.137-3.fc9.x86_64

elfutils-libs-0.137-3.fc9.x86_64

elfinfo-1.1-4.fc9.x86_64

 

Is there a document describing the installation and debugging process

of libvirt ?

 

regards

Danny

 

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]