[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] While connecting through xen+ssh, virConnectClose doesn't close the connection



Hi,

I'm trying to create a Perl script with Sys::Virt (perl bindings). I'm also using Virsh for testing / experimenting, so this is in no way related to my Perl script (I mentioned it because there might be a sollution that I could use / implement).

When connecting to libvirtd using a xen+ssh// connection, it connects, libvirt commands are executing, but on virsh "quit" (or when my script terminates), the connection is blocked. It bothers me because my script doesn't terminate.

While running with LIBVIRT_DEBUG=1 I get the following messages:

14:30:51.086: debug : virDomainFree:1893 : domain=0x8791ff8
14:30:51.086: debug : virUnrefDomain:367 : unref domain 0x8791ff8 malcolm 1
14:30:51.086: debug : virReleaseDomain:325 : release domain 0x8791ff8 malcolm
14:30:51.087: debug : virReleaseDomain:337 : unref connection 0x87308a0 3
14:30:51.087: debug : virDomainFree:1893 : domain=0x8791f28
14:30:51.087: debug : virUnrefDomain:367 : unref domain 0x8791f28 Domain-0 1
14:30:51.087: debug : virReleaseDomain:325 : release domain 0x8791f28 Domain-0
14:30:51.087: debug : virReleaseDomain:337 : unref connection 0x87308a0 2
14:30:51.087: debug : virConnectClose:1203 : conn=0x87308a0
14:30:51.087: debug : call:6947 : Doing call 2 (nil)
14:30:51.087: debug : call:7017 : We have the buck 2 0x8796f68 0x8796f68
14:30:51.090: debug : processCallRecvLen:6605 : Got length, now need 28 total (24 more)
14:30:51.090: debug : processCalls:6873 : Giving up the buck 2 0x8796f68 (nil)
14:30:51.090: debug : call:7048 : All done with our call 2 (nil) 0x8796f68


Is this normal?


Thanks,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]