[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] PATCH: Video device config



On Tue, Jul 07, 2009 at 10:17:18PM +0100, Tom Hughes wrote:
> I recently posted a patch on the RedHat bugzilla (bug #467038) to add a 
> model attribute to the graphics element so that the different graphics 
> cards supported by QEMU could be selected.
> 
> Apparently that approach has been rejected in the past however, and the 
> preferred approach is to add a separate video element.
> 
> I've taken the patch that Daniel Berrange posted here a few months ago 
> that added the necessary XML handling for the new element and extended 
> it by filling in the QEMU driver code to make it use the model details 
> as well as fixing the default video model for XEN domains as per the 
> list of outstanding issues given with the original patch.

Doh, I was literally about to post an update of my patches when I
saw this. The QEMU stuff is a little harder than you've got, since
the -vga arg was only added in QEMU 0.10.0, so we need to detect
the syntax

>  - Add RNG XML schemas & website docs

My patches cover this now

>  - Make Xen drivers use this info for setting stdvga=1|0 config arg
>  - Make VirtualBox use this info in whatever way it needs

I've not attempted either of these.

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]