[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] PATCH: Video device config



On Tue, Jul 07, 2009 at 10:17:18PM +0100, Tom Hughes wrote:
> I recently posted a patch on the RedHat bugzilla (bug #467038) to add a  
> model attribute to the graphics element so that the different graphics  
> cards supported by QEMU could be selected.
>
> Apparently that approach has been rejected in the past however, and the  
> preferred approach is to add a separate video element.
>
> I've taken the patch that Daniel Berrange posted here a few months ago  
> that added the necessary XML handling for the new element and extended  
> it by filling in the QEMU driver code to make it use the model details  
> as well as fixing the default video model for XEN domains as per the  
> list of outstanding issues given with the original patch.
>
> The updated patch is attached, and based on the list of outstanding  
> tasks given before what remains to be done is:

  Upon rereading that patch it seems that Dan's version is a superset,
am I missing something ?

>  - Add RNG XML schemas & website docs

  first part is in Dan patch, docs are needed that's right

>  - Make Xen drivers use this info for setting stdvga=1|0 config arg
>  - Make VirtualBox use this info in whatever way it needs

  I think those 2 drivers also need to be updated, maybe Pritesh will
be able to fill in once Dan has commited his set.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]