[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 4/4] Switch to using a unix socket for the qemu monitor



On Thu, Jul 09, 2009 at 08:09:46PM +0100, Mark McLoughlin wrote:
> We keep support for the pty based monitor so that we can re-connect
> to VMs started by older versions of libvirtd.
> 
> * src/domain_conf.c: handle formatting and parsing unix monitors
> 
> * src/qemu_driver.c: add qemudOpenMonitorUnix(), remove the monitor
>   pty path searching from qemudFindCharDevicePTYs(), switch
>   qemudStartVMDaemon() and qemuDomainXMLToNative() to using a unix
>   monitor
> 
> * tests/qemuxml2argvtest.c: switch to using a unix monitor
> 
> * tests/qemuxml2argvdata/qemuxml2argv-*.args: update test data

It is worth noting that support for non-PTYs for -monitor only came
along in QEMU >= 0.9.0. Thus this patch entails droppping support
for QEMU 0.8.1 which we had previously supported.

IMHO, QEMU 0.8.1 is ancient[1] enough now, that this is not something
to worry about. It might be worth explicitly adding a check to the
function where we detect QEMU command line version to reject any
QEMU < 0.9.0 just to avoid surprises.

ACK


Daniel

[1] Fedora Core 6 was last to include that version IIRC
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]