[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 7/9] Split out code for handling incoming method call messages



On Tue, Jul 14, 2009 at 11:20:17AM +0100, Daniel P. Berrange wrote:
> The remoteDispatchClientRequest() method is currently hardwired to
> assume there is only one type of incoming message, a method call.
> To allow for alternate types of incoming messags, the code that is
> specific to method calls is being split into a separate method
> remoteDispatchClientCall
> 
> * qemud/dispatch.c: Move method call specific code out into
>   remoteDispatchClientCall. Add a helper remoteSerializeError
>   for returning error messages to client

  Okay, the split seems to also make the code more readable,

   ACK,

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]