[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt 0.6.4] Unable to set /domain/devices/serial[@port=1] as console?



On Thu, Jul 16, 2009 at 08:24:10PM -0500, Charles Duffy wrote:
> When I do a "virsh define" with the following:
> 
>     <serial type='file'>
>       <source path='/path/to/serial.log'/>
>       <target port='0'/>
>     </serial>
>     <serial type='pty'>
>       <target port='1'/>
>     </serial>
>     <console type='pty'>
>       <target port='1'/>
>     </console>
> 
> The result is this:
> 
>     <serial type='file'>
>       <source path='/path/to/serial.log'/>
>       <target port='0'/>
>     </serial>
>     <serial type='pty'>
>       <target port='1'/>
>     </serial>
>     <console type='file'>
>       <source path='/path/to/serial.log'/>
>       <target port='0'/>
>     </console>
> 
> ...a markedly different configuration.
> 
> Is this the result of a bug, or a known behavior I've failed to catch in 
> the docs?

Mostly a docs issue. The <console> element is defined to refer to the
first text console available for the guest. For Xen paravirt, this is
the xen xvc0/hvc0 paravirt console. For Xen/QEMU fullyvirt guests this
is currently defined to be the first serial port. In the very near
future I will make it possible to override this behaviour, ostensibly
to let us use VirtIO console. I hadn't considered the case that someone
might want to make the <console> match the secondary serial port, but
if practical I can try and make that work. 

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]