[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Split virDomainMigrate into functions.



Daniel P. Berrange wrote:
> On Fri, Jul 31, 2009 at 03:19:56PM +0200, Chris Lalancette wrote:
>> Re-factor virDomainMigrate to split out the version 1 and version 2
>> protocols into their own functions.  In reality, the two versions share
>> very little in common, so forcing them together in the same function was
>> just confusing.  This will also make adding tunnelled migration easier.
>>
>> Signed-off-by: Chris Lalancette <clalance redhat com>
>> ---
>>  src/libvirt.c |  258 ++++++++++++++++++++++++++++++++++-----------------------
>>  1 files changed, 155 insertions(+), 103 deletions(-)
>>
> 
>>  
>>  
>> +static virDomainPtr
>> +migrate_version_1 (virDomainPtr domain,
>> +                   virConnectPtr dconn,
>> +                   unsigned long flags,
>> +                   const char *dname,
>> +                   const char *uri,
>> +                   unsigned long bandwidth)
> 
> 
>> +static virDomainPtr
>> +migrate_version_2 (virDomainPtr domain,
>> +                   virConnectPtr dconn,
>> +                   unsigned long flags,
>> +                   const char *dname,
>> +                   const char *uri,
>> +                   unsigned long bandwidth)
> 
> 
>>   * @domain: a domain object
>> @@ -2930,140 +3070,52 @@ virDomainMigrate (virDomainPtr domain,
>>                    const char *uri,
>>                    unsigned long bandwidth)
>>  {
> 
> 
> ACK, but I'd prefer we didn't invent a new naming convention here,
> just do it as virDomainMigrateVersion2.

I was just sort-of following the convention from virConnect, where the internal
methods use _ instead of camelCase.  But I'm not married to the names at all,
I'll change them.

> 
> Please hold off committing this patch till after the 0.7.0 release.
> The rest of the bug fixes in this series can be applied now though

OK, cool, sounds good.  I probably won't have time to commit today (I need to
leave in < 10 minutes), but I'll do it on Sunday.

-- 
Chris Lalancette


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]