[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Problem compiling latest code from libvirt CVS



On Fri, Jun 05, 2009 at 01:01:59PM +0000, Fischer, Anna wrote:
> I am trying to build the latest libvirt checked out from CVS this morning, but I get an error message. I ran ./autostart, ./configure and then make.
> 
> Any idea what the problem here could be?
> 
> gcc -DHAVE_CONFIG_H -I. -I..    -I../gnulib/lib -I../gnulib/lib -I../include -I../include -I../src -I/usr/include/libxml2      -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls -Wno-sign-compare -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fasynchronous-unwind-tables  -DLOCAL_STATE_DIR="\"/usr/local/var\""  -DSYSCONF_DIR="\"/usr/local/etc\"" -DQEMUD_PID_FILE="\"\"" -DREMOTE_PID_FILE="\"/usr/local/var/run/libvirtd.pid\"" -DGETTEXT_PACKAGE=\"libvirt\"  -g -O2 -MT libvirtd-remote_protocol.o -MD -MP -MF .deps/libvirtd-remote_protocol.Tpo -c -o libvirtd-remote_protocol.o `test -f 'remote_protocol.c' || echo './'`remote_protocol.c
> mv -f .deps/libvirtd-remote_protocol.Tpo .deps/libvirtd-remote_protocol.Po
> /bin/sh ../mylibtool --tag=CC   --mode=link gcc -I../gnulib/lib -I../gnulib/lib -I../include -I../include -I../src -I/usr/include/libxml2      -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls -Wno-sign-compare -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fasynchronous-unwind-tables  -DLOCAL_STATE_DIR="\"/usr/local/var\""  -DSYSCONF_DIR="\"/usr/local/etc\"" -DQEMUD_PID_FILE="\"\"" -DREMOTE_PID_FILE="\"/usr/local/var/run/libvirtd.pid\"" -DGETTEXT_PACKAGE=\"libvirt\"  -g -O2 -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls -Wno-sign-compare -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fasynchronous-unwind-tables    -o libvirtd libvirtd-event.o libvirtd-qemud.o libvirtd-remote.o libvirtd-remote_prot
>  ocol.o  -lxml2   -lgnutls -lpthread  -lsasl2   ../src/libvirt_driver_qemu.la ../src/libvirt_driver_lxc.la ../src/libvirt_driver_uml.la  ../src/libvirt_driver_storage.la ../src/libvirt_driver_network.la  ../src/libvirt.la  ../gnulib/lib/libgnu.la  -lpthread 
> (LD) -o libvirtd libvirtd-event.o libvirtd-qemud.o libvirtd-remote.o libvirtd-remote_protocol.o
> ../src/.libs/libvirt_driver_storage.a(storage_backend.o): In function `virStorageBackendWaitForDevices':
> /home/af/vepa/libvirt/libvirt/src/storage_backend.c:262: undefined reference to `virNodeDeviceWaitForDevices'
> collect2: ld returned 1 exit status
> make[3]: *** [libvirtd] Error 1

Can you send the end of the 'configure' output, starting from where
it says:

configure: 
configure: Configuration summary
configure: =====================
configure: 

I'd guess there is some combination of build options you have that
is causing the problem.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]