[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/3] Detect newer qemu-kvm versions



On Wed, Jun 10, 2009 at 09:02:40PM +0100, Mark McLoughlin wrote:
> The KVM version string can be one of the following:
> 
>   - qemu-kvm-x.y.z in stable releases
>   - kvm-XX for kvm versions up to kvm-85
>   - qemu-kvm-devel-XX for kvm version kvm-86 and later

  Any chance to secure an API in the future from those guys ?

But anyway we need to deal with the mess so ...

> There are only a few of places where we need to detect
> differences between KVM versions based on 0.9.1:
> 
>   1) VNET_HDR introduced in kvm-74
> 
>   2) -incoming tcp introduced in kvm-79
> 
>   3) -incoming exec introduced in kvm-80
> 
>   4) -incoming stdio in all earlier kvm versions
> 
> With qemu-kvm-0.10.x, we can now assume that (1) is available
> if it's a KVM release, (2) and (3) is always available and
> (4) is never available.
> 
> So, from now on we should only need to check the qemu version
> number and the "is_kvm" flag for detecting feature availability.
> We only need the KVM version number for older releases.
> 
> Signed-off-by: Mark McLoughlin <markmc redhat com>

  ACK, I don't see a good way to avoid this,

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]