[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Remove redundant monitorWatch



Cole Robinson wrote:
> Daniel P. Berrange wrote:
>> On Mon, Feb 16, 2009 at 06:42:11PM -0500, Cole Robinson wrote:
>>> For some reason there are two VMDef members being used to keep track of
>>> monitor event handles: monitor_watch and monitorWatch. Remove the latter.
>>
>> Can you remove the 'monitor_watch' instead - all the other variables
>> in the domain_conf.h structs use leading capital letters for separating
>> words, and not underscores.
>
> Yup, sorry for not noticing that before.
>
> Updated patch attached.
...
>     Remove redundant monitor watch variable (s/monitor_watch/monitorWatch/)
>
> diff --git a/src/domain_conf.c b/src/domain_conf.c
> index 622665c..603b87b 100644
> --- a/src/domain_conf.c
> +++ b/src/domain_conf.c
> @@ -503,7 +503,7 @@ virDomainObjPtr virDomainAssignDef(virConnectPtr conn,
>      virDomainObjLock(domain);
>      domain->state = VIR_DOMAIN_SHUTOFF;
>      domain->def = def;
> -    domain->monitor_watch = -1;
> +    domain->monitorWatch = -1;

Looks fine and obviously safe.
ACK


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]