[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] qemu-kvm networking speed



On Thu, Mar 12, 2009 at 04:18:27PM -0400, Bryan_Coleman dart biz wrote:
> Thank you for the suggestion.  Switching to virtio and/or e1000 helped but 
> still was not able to exceed 450Mb/s.  It took me awhile to figure out you 
> had to either restart or reload libvirtd for the changes to take effect. 
> Is there anything else I could check/change to approach 1000Mb/s or 
> higher?

I think it really comes down to tuning of the host & guest OS at that point,
and making sure you have the absolute latest KVM host side, and absolute
latest guest kernel. Early VirtIO guest drivers were not hugely optimized.
There has been alot of optimization work in .27, .28, .29 kernels getting
better all the time. Also make sure things like checksum/segmentation
offload are enabled (ethtool settings). Also things like iptables can have
impact - so worth checking how that's setup in host - eg, turn off
net.bridge.bridge-nf-call-{iptables,arptables,ip6tables} sysctl settings
to avoid having bridged traffic in host pushed up through iptables.
This isn't really my area of expertize, so you'll probably get more help
asking on the kvm development mailing list

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]