[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Latest git tree doesn't compile



On Wed, May 13, 2009 at 05:50:42PM +0200, Florian Vichot wrote:
> Hello everyone,
> 
> I just got the latest and grooviest libvirt from the git tree at :
> git://git.et.redhat.com/libvirt.git
> but compiling fails:

> lxc_container.c: In function 'lxcContainerDropCapabilities':
> lxc_container.c:657: error: 'PR_CAPBSET_DROP' undeclared (first use in
> this function)
> lxc_container.c:657: error: (Each undeclared identifier is reported only
> once
> lxc_container.c:657: error: for each function it appears in.)
> 
> Apparently, my machine doesn't have the PR_CAPBSET_DROP flag defined.
> It's inexistent in sys/capability.h and "man prctl".

  I have it in /usr/include/linux/prctl.h

#define PR_CAPBSET_DROP 24

> I run a Ubuntu 8.04, kernel is 2.6.24-24-openvz.

  2.6.24 is probably too old I see the patch from Nov 2007
http://lkml.indiana.edu/hypermail/linux/kernel/0711.3/0496.html

> Am I missing headers that are not tested for in the ./configure ? If
> not, any way that functionality could be disabled on distros that don't
> support it ?

  We could possibly make the #ifndef / #endif and
let the call fail if someone used the driver instead of breaking at
compile time.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]