[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Latest git tree doesn't compile



>> I run a Ubuntu 8.04, kernel is 2.6.24-24-openvz.
> 
>   2.6.24 is probably too old I see the patch from Nov 2007
> http://lkml.indiana.edu/hypermail/linux/kernel/0711.3/0496.html
> 
>> Am I missing headers that are not tested for in the ./configure ? If
>> not, any way that functionality could be disabled on distros that don't
>> support it ?
> 
>   We could possibly make the #ifndef / #endif and
> let the call fail if someone used the driver instead of breaking at
> compile time.

Bah, after some thought, IMHO, no need to bother. For the time being, I
can compile libvirt fine by disabling LXC, which is just as good since I
don't use it.

I notified the bug because I'm using the latest Ubuntu distro with LTS
(Long Term Support), which is the one we usually advise to our clients,
and there won't be a new LTS before April 2010. So that would have been
a long time to wait to get the LXC functionnality in libvirt on a LTS
version.

But such is life :) So if I have clients that *really* want LXC, they
will have to depart from Ubuntu 8.04, and use one of the more recent,
non-LTS distros.

Florian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]