[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] error: failed to connect to the hypervisor



Hi,

I installed the libvirt with the following configure options as an unprivileged user, I am planning to use it just for qemu/kvm:

./configure --without-xen --without-lxc --without-uml --without-openvz --without-vbox --without-numactl --prefix=/some/nonstandard/dir
make
make install

--without-numactl is added because of a compilation error. I am not sure whether it is completely necessary or not. If you think it has effect on the error, please state the reason.

After installation I got the following error when I tried to run the virsh without any options:

error: failed to connect to the hypervisor

With the following command line error was "Segmentation Fault":

virsh -c qemu:///session.

Qemu executable path: /usr/local/bin/qemu-system-x86_64 and it is defined on the path. Libvirt daemon is failing with the same error too.

System ---> Scientific Linux SL release 4.7 (Beryllium), Kernel version: 2.6.28.2, libvirt version: 0.6.3

Any ideas?

P.S.: Is there a way to compile static virsh executable? I tried altering make files, configure options, linker flags and compiler flags but no luck. "ldd virsh" command should say "not a dynamic executable" after compilation.

Thanks,

Erkan Unal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]