[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Re: BUG REPORT: -net tap, fd=X does not work correctly in kvm-86



Hi,
are You sure about that? at least ifname seems to be valid parameter,
I'm using it for naming host interfaces for tens of my kvms...
and both are stated in kvm-85 help:

-net tap[,vlan=n][,name=str][,fd=h][,ifname=name][,script=file][,downscript=dfile]

in general the error message Josh is posting seems to be talking
about something else anyways: invalid parameter 15...

On Fri, May 22, 2009 at 09:12:55PM -0500, Anthony Liguori wrote:
> Josh Wilsdon wrote:
>> We are doing work with libvirt 0.6.3 through which we have started
>> virtual machines.  Using the same "create" command with the same
>> storage, the same everything else this configuration works with both
>> kvm-84 and kvm-85.  When I built a fresh version of kvm-86 this
>> stopped working with an error:
>>
>> qemu: invalid parameter '15' in 'fd=15,script=,vlan=0,ifname=vnet0'
>>   
>
> It's a libvirt bug.  script and ifname have never been valid parameters  
> for -net tap.  Historically, -net has ignored unknown options but  
> recently, it now throws an error when encountering an unsupported option.
>
> Regards,
>
> Anthony Liguori
> --
> To unsubscribe from this list: send the line "unsubscribe kvm" in
> the body of a message to majordomo vger kernel org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]