[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Re: BUG REPORT: -net tap, fd=X does not work correctly in kvm-86



On Fri, May 22, 2009 at 09:12:55PM -0500, Anthony Liguori wrote:
> Josh Wilsdon wrote:
> >We are doing work with libvirt 0.6.3 through which we have started
> >virtual machines.  Using the same "create" command with the same
> >storage, the same everything else this configuration works with both
> >kvm-84 and kvm-85.  When I built a fresh version of kvm-86 this
> >stopped working with an error:
> >
> >qemu: invalid parameter '15' in 'fd=15,script=,vlan=0,ifname=vnet0'
> >  
> 
> It's a libvirt bug.  script and ifname have never been valid parameters 
> for -net tap.  Historically, -net has ignored unknown options but 
> recently, it now throws an error when encountering an unsupported option.

IIRC, the reason libvirt had been passing the ifname=XXX arg, is because 
Xenner wanted it know the name associated with the TAP device, and would
then open it, rather than taking the FD passed in. Xenner long ago gained
code todo the reverse fd -> name lookup though, so we should just kill
this bogus code in libvirt now and drop ifname & script= args when passing
an FD.

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]