[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] F12beta guest will not connect to LAN via bridge



Setup:
HOST: F11 x86_64
GUEST: F12beta x86_64

I have a number of guests setup on this host and all connect without a problem with the 'br0' bridge on the host. I created a new guest and loaded F12beta on it. I defined it to also use 'br0' networking but this guest cannot ping anything on the LAN. All the other guests have no problems communicating to addresses on the LAN.
Details:

### on HOST:
# brctl showmacs br0
port no mac addr                is local?       ageing timer
 1     00:0b:82:11:bc:cb       no                15.88
 3     00:0c:01:30:50:00       no                16.37
 2     00:0c:01:40:50:00       no                 2.51
 1     00:0c:29:e3:bc:ee       no                 0.49
 1     00:18:f8:48:27:15       no                 2.51
 1     00:18:f8:9b:ba:b4       no               116.39
 1     00:18:f8:9b:ba:b5       no                20.60
 1     00:1a:4d:5e:f6:36       no               156.43
 1     00:24:1d:19:05:cf       yes                0.00
 3     06:1d:1d:7a:31:9b       yes                0.00
 2     06:ba:11:dd:7b:08       yes                0.00
 1     54:52:00:24:5e:cf       no                28.93

# EXISTING GUEST: network interface in xml file:
   <interface type='bridge'>
     <mac address='00:0c:01:30:50:00'/>
     <source bridge='br0'/>
     <target dev='vnet0'/>
     <model type='virtio'/>
   </interface>

# NEW GUEST: network interface in xml file:
   <interface type='bridge'>
     <mac address='00:0c:01:40:50:00'/>
     <source bridge='br0'/>
     <target dev='vnet0'/>
     <model type='virtio'/>
   </interface>

### on EXISTING GUEST:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
HWADDR=00:0c:01:30:50:00
IPADDR=192.168.1.200
NETMASK=255.255.255.0
NETWORK=192.168.1.0

### on NEW GUEST:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
HWADDR=00:0c:01:40:50:00
IPADDR=192.168.1.210
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
NETWORK=192.168.1.0
TYPE=Ethernet
IPV6INIT=no
USERCTL=no

### on EXISTING GUEST:
# ping 192.168.1.1
succeeds

### on NEW GUEST:
# ping 192.168.1.1
fails with Destination Host Unreachable


Is there something else I need to configure in F12beta to get this working?

-Gerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]