[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] starting vm using virsh somewhat fails



Hi all,


I have started a vm using virsh create domain.xml and it starts for a
second and then its destroyed automatically. When I do xm create -f
<xm cfg> it works fine.

I don't know if this is relevant but

virsh net-list --all
Name                 State      Autostart
-----------------------------------------
default              inactive   yes

virsh net-start default
error: Failed to start network default
error: Failed to open file '/etc/sysconfig/system-config-firewall': No
such file or directory

Can this be the problem? Why do I need /etc/sysconfig/system-config-firewall?


Domain XML Description: (converted from a xm cfg file)
<domain type='xen'>
  <name>rtiago_test</name>
  <uuid>8f07fe28-753f-2729-d76d-bdbd892f949a</uuid>
  <memory>2560000</memory>
  <currentMemory>200000</currentMemory>
  <vcpu>8</vcpu>
  <bootloader>/usr/bin/pygrub</bootloader>
  <os>
    <type arch='x86_64' machine='xenpv'>linux</type>
    <cmdline>rtiago</cmdline>
  </os>
  <clock offset='utc'/>
  <on_poweroff>restart</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <disk type='file' device='disk'>
      <driver name='file'/>
      <source file='/images/fc-6.img'/>
      <target dev='xvda1' bus='xen'/>
    </disk>
</domain>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]