[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Security driver on el5



On Sat, Nov 14, 2009 at 01:59:33PM +0100, Daniel Berteaud wrote:
> Hi.
> 
> I'm running libvirt (0.7.2) on a CentOS 5.4 host. It's working quite
> well, but only if I configure selinux in permissive mode. I've tried to
> build libvirt with selinux enabled, but no matter what I try, it's still
> disabled. After some searching, I've found that:
> 
> http://article.gmane.org/gmane.comp.emulators.libvirt/12282
> 
> "- Added a configure.in check for selinux_virtual_domain_context_path()
>    and selinux_virtual_image_context_path() and make it disable the
>    SELinux driver if these aren't found. These functions are new on
>    F11, so we don't want to break build on RHEL-5 & earlier Fedora."
> 
> Does this means there's no way to get selinux security driver on el5
> (or anything before fedora 11) ?

That is correct. The RHEL5  SELinux libraries, and policy are too old 
for the security driver to work. It is Fedora 11 or newer only.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]