[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] cann't connect kvm hypervisor



Title: cann't connect kvm hypervisor

Hello,
 I'm new of Opennebula. I have installed KVM im my remote node. But when I
 want to check the KVM in the node, I can't connect to the hypervisor.

 --------------------------------------------------------------------
 root forest:/var/run/libvirt# virsh -c qemu:///localhost/system list
 Connecting to uri: qemu:///system
 error: failed to connect to the hypervisor
 --------------------------------------------------------------------

 Can somebody tell me why virsh doesn't work? And how I can fix it?

I think that it's maybe the problem of libvirt.  

 Any helps would be very appreciated?

 Thanks

 Zhentao

-----Original Message-----
From: tinova79 gmail com on behalf of Tino Vazquez
Sent: Mon 10/5/2009 4:33 PM
To: Shi Jin
Cc: Liu, Zhentao; users lists opennebula org
Subject: Re: [one-users] cann't connect kvm hypervisor

Hi there,

I would suggest forwarding this question to the libvirt mailing list,
other people there may know the best procedure to deal with this.

Regards,

-Tino

--
Constantino Vázquez, Grid Technology Engineer/Researcher:
http://www.dsa-research.org/tinova
DSA Research Group: http://dsa-research.org
Globus GridWay Metascheduler: http://www.GridWay.org
OpenNebula Virtual Infrastructure Engine: http://www.OpenNebula.org



On Mon, Oct 5, 2009 at 4:30 PM, Shi Jin <jinzishuai gmail com> wrote:
> I had similar problems earlier.
> The only solution I found without rebooting the machine is to killall
> kvm on the node.
> I would also appreciate any suggestion to better handle this problem.
> Thanks.
>
> Shi
>
> On Mon, Oct 5, 2009 at 5:56 AM, Liu, Zhentao
> <Zhentao Liu fokus fraunhofer de> wrote:
>> Hi Tino
>>
>> I have checked that libvirtd deaemon is running. I have also restarted
>> libvirtd deaemon, but I can't still connect to kvm hypervisor.
>> -----------------------------------------------------------
>> root forest:/var/run/libvirt# /etc/init.d/libvirt-bin start
>>  * Starting libvirt management daemon libvirtd                           [
>> OK ]
>> root forest:/var/run/libvirt# virsh -c qemu:///system list
>>
>> Connecting to uri: qemu:///system
>> error: failed to connect to the hypervisor
>> -------------------------------------------------------------
>>
>> other ideas?
>>
>> Thanks
>>
>> Zhentao
>>
>> -----Original Message-----
>> From: tinova79 gmail com on behalf of Tino Vazquez
>> Sent: Mon 10/5/2009 1:43 PM
>> To: Liu, Zhentao
>> Cc: users lists opennebula org
>> Subject: Re: [one-users] cann't connect kvm hypervisor
>>
>> Hi Zhentao,
>>
>> Can you check that the libvirtd deaemon is running in the remote node?
>>
>> Regards,
>>
>> -Tino
>>
>> --
>> Constantino Vázquez, Grid Technology Engineer/Researcher:
>> http://www.dsa-research.org/tinova
>> DSA Research Group: http://dsa-research.org
>> Globus GridWay Metascheduler: http://www.GridWay.org
>> OpenNebula Virtual Infrastructure Engine: http://www.OpenNebula.org
>>
>>
>>
>> On Mon, Oct 5, 2009 at 1:30 PM, Liu, Zhentao
>> <Zhentao Liu fokus fraunhofer de> wrote:
>>> Hello,
>>>
>>> I'm new of Opennebula. I have installed KVM im my remote node. But when I
>>> want to check the KVM in the node, I can't connect to the hypervisor.
>>>
>>> --------------------------------------------------------------------
>>> root forest:/var/run/libvirt# virsh -c qemu:///localhost/system list
>>> Connecting to uri: qemu:///system
>>> error: failed to connect to the hypervisor
>>> --------------------------------------------------------------------
>>>
>>> Can somebody tell me why virsh doesn't work? And how I can fix it?
>>>
>>> Any helps would be very appreciated?
>>>
>>> Thanks
>>>
>>> Zhentao
>>>
>>> _______________________________________________
>>> Users mailing list
>>> Users lists opennebula org
>>> http://lists.opennebula.org/listinfo.cgi/users-opennebula.org
>>>
>>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> Users lists opennebula org
>> http://lists.opennebula.org/listinfo.cgi/users-opennebula.org
>>
>>
>
>
>
> --
> Shi Jin, Ph.D.
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]