[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Application using libvirt crashes when having concurrent TLS connections (gnutls problem)



On Monday 05 October 2009 14:43:05 Daniel P. Berrange wrote:
> On Fri, Oct 02, 2009 at 09:59:27PM +0200, Thomas Treutner wrote:
> > Hi list,
> >
> > I was wondering about the status of this bug:
> >
> > 	https://bugzilla.redhat.com/show_bug.cgi?id=512367
>
> Patch proposed but the original reporter never indicated whether it
> actually fixed the problem or not. If someone can confirm ....

Now I get:

remote_internal.c:1092: error: 'GCRY_THREAD_OPTION_VERSION' undeclared here 
(not in a function)

/usr/include/gcrypt.h is there. I did a ./configure, make clean, make. System 
is Ubuntu 8.04. 


When I close my connections properly, I run into this, most probably whent he 
Java garbage collector runs:

https://www.redhat.com/archives/libvir-list/2009-March/msg00453.html

..although I didn't see a segfault yet. From what I read this bug is fixed in 
the Python bindings. Is the error message I get noisy but harmless or do the 
Java bindings need a patch too?


kr,
thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]