[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Creating Guest OS in Virtual Box



hi,

When I am trying to apply the patch I got this error

$git apply vboxpatch
error: patch failed: src/vbox/vbox_tmpl.c:3286
error: src/vbox/vbox_tmpl.c: patch does not apply

how can I clear this error?
Am I using the right command to apply patch? Please correct me.

Thank you.
On 10/5/09, Pritesh Kothari <Pritesh Kothari sun com> wrote:
> Hi Santosh,
>
> apply this patch
> http://www.mail-archive.com/libvir-list redhat com/msg16797.html
> and hopefully it should work
>
> Regards,
> Pritesh
>
> On Monday 05 October 2009 14:51:33 santosh gandham wrote:
>> Hi,
>>
>>  I am trying to create Guest OS (VM) in virtualBox throught libvirt. I
>> installed libvirt 0.7.0 and created the template as
>>
>> <domain type='vbox'>
>> 	<name>ubuntu</name>
>>
>> 	<os>
>> 		<type>hvm</type>
>> 		<boot dev='hd'/>
>> 	</os>
>>
>>          <memory>542720</memory>
>>          <vcpu>1</vcpu>
>>
>> 	<devices>
>> 		<disk type='file' device='disk'>
>> 			<source file='/home/santhosh/Desktop/ubuntu9.vdi'/>
>> 			<target dev='hdd'/>
>>
>> 		</disk>
>> 		<graphics type='rdp' port='3386'/>
>> 	</devices>
>> </domain>
>>
>> Then I issued this command
>>
>>   $ virsh -c vbox:///session define /home/santhosh/Desktop/ubun.tmpl
>>
>>   Domain ubuntu defined from /home/santhosh/Desktop/ubun.tmpl
>>
>> When I open VirtualBox, it has created a domain named "ubuntu". All
>> the parameters specified in the template file are set except  "Hard
>> disks" . So, when I start the VM, I am left with boot errors
>>
>> 00:00:06.318 Guest Log: BIOS: int13_harddisk: function 02, unmapped
>> device for ELDL=80
>> 00:00:06.319 Guest Log: BIOS: Boot from Hard Disk 0 failed
>> 00:00:06.321 Guest Log: Could not read from the boot medium! System
>> halted.
>>
>> It is unable to boot from the disk image which I specified in the
>> template and I am sure the path  specified to disk image in the
>> template is correct.
>>
>> I am unable to diagnize and find where is the error. Can any one help
>> me here to know what might be the problem and what should I do.
>>
>> Thank you.
>>
>>
>>
>> Best Regards,
>> Gandham Santhosh
>>
>> --
>> Libvir-list mailing list
>> Libvir-list redhat com
>> https://www.redhat.com/mailman/listinfo/libvir-list
>
>
>


-- 
Gandham Santhosh


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]