[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Qemu-devel] Re: [libvirt] dynamic scsi disk attach seems to be broken in qemu(-kvm)-0.11, libvirt-0.7.1



On Fri, Oct 9, 2009 at 9:38 AM, Anthony Liguori <anthony codemonkey ws> wrote:
>>> I would like some advice on how to proceed with this bug, and where
>>> the solution lies...in qemu or in libvirt.  Ultimately, I would like
>>> the behavior we had in our previous release with kvm-84 and
>>> libvirt-0.6.1, where we could dynamically add scsi devices without a
>>> problem, using:
>>>  pci_add 1 storage file=/tmp/foo,if=scsi
>>>
>>> Can anyone else reproduce this?  Is this considered a regression by
>>> anyone else?  Where should I look to solve this, in libvirt, or in
>>> qemu?
>>>
>>
>> Independently of what I said about libvirt not implementing SCSI hotplug
>> with the right apporoach, the pci-add stuff should definitely work,  so if
>> it doesn't then this is a regression that needs to be fixed
>>
>
> There's definitely a bug somewhere.  When you add a second PCI controller,
> the controller shows up in the guest but the disk attached to the controller
> isn't visible.  Rescanning the scsi bus does not make the disk appear
> either.

Okay, thanks for confirming this, Anthony.

I have added a task against upstream QEMU at:
 * https://bugs.edge.launchpad.net/ubuntu/+source/qemu-kvm/+bug/432154

:-Dustin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]