[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/2] RPM spec file updated with glusterfs dependency



On Sat, Aug 29, 2009 at 12:20:11AM +0200, Gerrit Slomma wrote:
> >On Tue, Jul 07, 2009 at 05:47:56AM -0700, Harshavardhana wrote:
> >> Add new dependency for glusterfs rpm.
> >[...]
> >> +# For glusterfs 
> >> +Requires: glusterfs-client >= 2.0.2
> >>  %endif
> >
> >  why 2.0.2 ? is taht a hard requirement ? In Fedora/Rawhide we have
> >only 2.0.1 at the moment,
>
> Tested libvirt-0.7.0 today.
> And this requirement really breaks installation of builds on 
> RHEL/CentOS/ScientificLinux.
> The newest available built for glusterfs is those systems is 
> glusterfs-client-1.3.8 from freshrpms.
> Even --without-storage-fs does not help a bit, must be pulled in implicitly?

No, its an explicitly RPM dependancy

> rpm -pq --requires libvirt-0.7.0-1.x86_64.rpm
> (...)
> glusterfs-client >= 2.0.1
> (...)
> 
> Is this patched in upcoming 0.7.1 or how could i go around this issue?

We should hjust make this dependancy conditional onn fedora >= 11, since
no earlier Fedora or RHEL has this available.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]