[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Automagically check if libssh2 is new enough for Phyp-support to be build



Daniel Veillard wrote:
On Fri, Sep 04, 2009 at 02:45:57PM +0200, Maximilian Wilhelm wrote:
Hi!

My buildbot spotted a problem with the latest changes to Phyp, as the
function libssh2_session_block_directions() only is available with
libssh2 version 1.0 and later.

At least on Debian Lenny there is an older one which prevents libVirt
from building, so I updated the configure.in script to add another
piece of magic (and thereby fixed the indenation of the Phypchecks).

See attached patch.

  Okay I revamped the patch a bit to set LIBS with -lssh2 before trying
to link, that seems to fix the problem I was having with your patch,

  applied and commited.
  Dave could you double check on your F10 setup ?

Builds fine on F10 now.

Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]