[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] 0.7.1 compile fails on opensuse 11.1



Pritesh Kothari wrote:
>> it seems openSuSE 11.1 does not come with a pkgconfig for the
>> device-mapper-devel package. I created a bug [1] for opensuse but was
>> also told to mention it here so configure.in could be patched once the
>> bug was fixed.
> 
> Hi All,
> 
> Just fixed this for ubuntu (should work now for suse as well) with some help 
> from danpb and DV.
> 
> The patch is attached below.

It does not work for me. After applying the patch, configure still fails
 with

checking for DEVMAPPER... no
configure: error: You must install device-mapper-devel >= 0.0 to compile
libvirt

config.log says:

configure:48143: checking for DEVMAPPER
configure:48150: $PKG_CONFIG --exists --print-errors "devmapper >=
$DEVMAPPER_REQUIRED"
Package devmapper was not found in the pkg-config search path.
Perhaps you should add the directory containing `devmapper.pc'
to the PKG_CONFIG_PATH environment variable
No package 'devmapper' found
configure:48153: $? = 1
configure:48166: $PKG_CONFIG --exists --print-errors "devmapper >=
$DEVMAPPER_REQUIRED"
Package devmapper was not found in the pkg-config search path.
Perhaps you should add the directory containing `devmapper.pc'
to the PKG_CONFIG_PATH environment variable
No package 'devmapper' found
configure:48169: $? = 1
No package 'devmapper' found
configure:48196: result: no
configure:48199: error: You must install device-mapper-devel >= 0.0 to
compile libvirt

Version info:
rpm -qa|grep device-mapper
device-mapper-1.02.27-7.1
device-mapper-devel-1.02.27-7.1

Regards
Dominik


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]