[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] building libvirtd fails on libxml-2



Looks like make install in the python dir does nothing:

[root earth python]# pwd
/root/Desktop/libvirt-0.7.1/python
[root earth python]# make
Making all in .
make[1]: Entering directory `/root/Desktop/libvirt-0.7.1/python'
make[1]: Nothing to be done for `all-am'.
make[1]: Leaving directory `/root/Desktop/libvirt-0.7.1/python'
Making all in tests
make[1]: Entering directory `/root/Desktop/libvirt-0.7.1/python/tests'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/Desktop/libvirt-0.7.1/python/tests'

[root earth python]# make install
Making install in .
make[1]: Entering directory `/root/Desktop/libvirt-0.7.1/python'
make[2]: Entering directory `/root/Desktop/libvirt-0.7.1/python'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/lib/python2.4/site-packages" || /bin/mkdir -p "/usr/local/lib/python2.4/site-packages"
make[2]: Leaving directory `/root/Desktop/libvirt-0.7.1/python'
make[1]: Leaving directory `/root/Desktop/libvirt-0.7.1/python'
Making install in tests
make[1]: Entering directory `/root/Desktop/libvirt-0.7.1/python/tests'
make[2]: Entering directory `/root/Desktop/libvirt-0.7.1/python/tests'
make[2]: Nothing to be done for `install-exec-am'.
/bin/sh ../../build-aux/mkinstalldirs /usr/local/share/doc/libvirt-python-0.7.1/examples
(for test in basic.py create.py uuid.py error.py node.py; \
          do /usr/bin/install -c -m 0644 ./$test /usr/local/share/doc/libvirt-python-0.7.1/examples ; done)
make[2]: Leaving directory `/root/Desktop/libvirt-0.7.1/python/tests'
make[1]: Leaving directory `/root/Desktop/libvirt-0.7.1/python/tests'

Dan


On Wed, Sep 23, 2009 at 5:41 PM, Dan Bar Dov <bardov gmail com> wrote:
Right.
Now after it compiled and installed, I get:
ImportError: No module named libvirtmod

That after I manually entered the python dir and installed libvirt.py since the Makefile
has all of the python generation and installation commented out.

What I cannot figure out is what generates libvirtmod


Dan

On Wed, Sep 23, 2009 at 5:40 PM, Daniel Veillard <veillard redhat com> wrote:
On Wed, Sep 23, 2009 at 04:21:32PM +0200, Paolo Bonzini wrote:
> On 09/23/2009 03:23 PM, Dan Bar Dov wrote:
>> I'm running on Centos5.3
>> Building using:
>> ./autogen.sh --prefix=/usr
>>
>> configure fails with
>> checking libxml2 xml2-config >= 2.6.0 ... configure: error: Could not
>> find libxml2 anywhere (see config.log for details).
>>
>> but rpm -qa | grep libxml2
>> libxml2-python-2.6.26-2.1.2.7
>> libxml2-2.6.26-2.1.2.7
>> libxml2-2.6.26-2.1.2.7
>>
>> So what's the problem, or better yet, how to fix it?
>
> I suppose you lack the -devel package?

 Yes looks like it :-)

Daniel

--
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]