[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] virtio network problems with kvm guests with 2.6.26 kernel



On Tue, Sep 29, 2009 at 02:39:59AM -0400, Jim Paris wrote:
> Hi,
> 
> After upgrading libvirt on one system, my kvm guests running a 2.6.26
> kernel with virtio networking could no longer communicate with the
> network.
> 
> It seems that the problem is caused by newer libvirt versions
> unconditionally enabling GSO support by setting IFF_VNET_HDR [1].
> 
> However, support for this feature is apparently broken in 2.6.26.
> Ubuntu seems to have also discovered this problem [2] and they
> currently work around it by removing GSO support from kvm [3].
>
> Currently, I'm running with a patched libvirt that never sets
> IFF_VNET_HDR, and it's working fine once again.
> 
> While this is not a libvirt problem per se, it certainly violated the
> principle of least surprise given that libvirt was the only thing that
> changed!  But I don't know if there's much that libvirt can do to
> avoid this problem, as it's really something that needs to get fixed
> in kvm, or the guest needs to be upgraded, or switched away from
> virtio.

libvirt probes to see if IFF_VNET_HDR is supported by the kernel
and if so, enables it.  If its broken in the kernel, the kernel
should have been patch, or had the flag disabled as its not really
practical for libvirt to special case this thing further

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]