[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] incorrect error message in virDomainNetDefParseXML



On Wed, Sep 30, 2009 at 05:51:07PM +0100, Mark McLoughlin wrote:
> On Wed, 2009-09-30 at 16:41 +0200, Florian Vichot wrote:
> > When declaring a <interface type="bridge"> tag, <source> needs a
> > "bridge" attribute, but the parser complains about a missing "dev"
> > attribute.
> > 
> > Florian
> 
> > diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c
> > index 868e865..86da022 100644
> > --- a/src/conf/domain_conf.c
> > +++ b/src/conf/domain_conf.c
> > @@ -1112,7 +1112,7 @@ virDomainNetDefParseXML(virConnectPtr conn,
> >      case VIR_DOMAIN_NET_TYPE_BRIDGE:
> >          if (bridge == NULL) {
> >              virDomainReportError(conn, VIR_ERR_INTERNAL_ERROR, "%s",
> > -    _("No <source> 'dev' attribute specified with <interface type='bridge'/>"));
> > +    _("No <source> 'bridge' attribute specified with <interface type='bridge'/>"));
> >              goto error;
> >          }
> >          def->data.bridge.brname = bridge;
> 
> Looks good to me, ACK
> 
> I assume DV will push this when pushing his  virDomainNetDefParseXML()
> fix

  Actually I was waitig for ACK so pushed separately :-)

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]