[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] hellolibvirt: no hypervisor driver available for xen:///



Hi,

I downloaded and built the latest libvirt source code 0.8. I installed the library in a custom directory libvirt-0.8.0-install/ keeping all other configurations default.

After this I tried to execute the example
hellolibvirt:

[hellolibvirt]# ./hellolibvirt xen
Attempting to connect to hypervisor
libvir: Remote error : unable to connect to '/root/ganeshp/libvirt-0.8.0-install/var/run/libvirt/libvirt-sock', libvirtd may need to be started: Connection refused
No connection to hypervisor
Parameter error when attempting to get last error

My libvirtd was running from /etc/init.d/libvirtd. Still why is it trying to connect to the newly built libvirtd?

I stopped the
/etc/init.d/libvirtd and started my newly built daemon:
[hellolibvirt]# /root/ganeshp/libvirt-0.8.0-install/sbin/libvirtd start &
04:47:07.534: warning : qemudStartup:1574 : Unable to create cgroup for driver: No such device or address
04:47:07.540: error : parse_socket:126 : cannot open /sys/devices/system/cpu/cpu1/topology/physical_package_id: No such file or directory
04:47:07.540: warning : qemudCapsInit:1068 : Failed to get host CPU
04:47:07.544: warning : lxcStartup:1835 : Unable to create cgroup for driver: No such device or address

After this I tried running hellolibvirt example again:
[hellolibvirt]# ./hellolibvirt xen
Attempting to connect to hypervisor
04:48:43.166: error : virLibConnError:450 : no hypervisor driver available for xen:///
libvir: error : no hypervisor driver available for xen:///
libvir: error : no hypervisor driver available for xen:///
No connection to hypervisor
Parameter error when attempting to get last error

I do not understand why the program is not able to find the xen driver. I am able to launch VMM GUI and create VMs using xen connection. The system already has xen hypervisor (3.1.0).

Even the newly built virsh gives similar errors. Whereas /usr/bin/virsh works perfectly fine.

Am I missing some configuration or dependency? Any pointers/suggestion would greatly help. Thanks.

Regards,
-Ganesh

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]