[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] BUG: attaching - detaching network device only works 7 times




"Daniel P. Berrange" <berrange redhat com> wrote on 04/15/2010 12:48:59 PM:

> Please respond to "Daniel P. Berrange"

>
> On Thu, Apr 15, 2010 at 12:19:48PM -0400, Stefan Berger wrote:
> > "Daniel P. Berrange" <berrange redhat com> wrote on 04/15/2010 07:50:51
> > AM:
> >
> >
> > >
> > >
> > > Even if that wasn't broken though, I don't see how NIC hotplug would
> > work
> > > in your scenario. That error message about Too Many NICs is becuase the
> > > 'nd_table' in QEMU's net.c has all fields set 'used = 1'. I don't see
> > any
> > > code which ever sets 'used = 0'.
> >
> > no code there that ever decreases nb_nic, so unplug doesn't seem to be
> > supported
> >
> > Would it be worth having such a simple test in libvirt repository itself
> > or is that a case for the TCK project?
>
> Yep, this is perfect candidate for a TCK test case. Take the 210-nic-hotplug.t
> test case, and make it attempt to plug+unplug a NIC 35 times in a row. This
> should test this particular bug, and also validate that PCI addresses are
> being reused correctly (there're only 31 pci slots that can be used at any
> 1 time)


another idea ... how about a daily 'weather report' from the Tck test suite sent to the mailing list?

   Stefan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]