[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] esx: Fix virtualHW.version generation



On 04/18/2010 02:32 PM, Matthias Bolte wrote:
> The supported virtualHW.version doesn't depend on the API version,
> but on the product version.
> ---
> @@ -774,42 +774,41 @@ esxVMX_ParseConfig(esxVI_Context *ctx, const char *vmx,
>          goto failure;
>      }
>  
> -    switch (apiVersion) {
> -      case esxVI_APIVersion_25:
> +    /*
> +     * virtualHW.version compatibility matrix:
> +     *
> +     *              4 7    API
> +     *   ESX 3.5    +      2.5
> +     *   ESX 4.0    + +    4.0
> +     *   GSX 2.0    + +    2.5
> +     */
> +    switch (productVersion) {
> +      case esxVI_ProductVersion_ESX35:
>          if (virtualHW_version != 4) {
>              ESX_ERROR(VIR_ERR_INTERNAL_ERROR,
> -                      _("Expecting VMX entry 'virtualHW.version' to be 4 for "
> -                        "VI API version 2.5 but found %lld"),
> +                      _("Expecting VMX entry 'virtualHW.version' to be 4 "
> +                        "but found %lld"),
>                        virtualHW_version);
>              goto failure;

ACK.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]