[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] seg fault when running snapshot-create



On Wed, Apr 21, 2010 at 05:16:21PM -0400, Chris Lalancette wrote:
> On 04/21/2010 04:34 PM, Stephen Shaw wrote:
> > I'm getting a seg fault when running virsh snapshot-create 1, but only
> > when virt-manager is open and connected.
> > 
> > Here is some of the debug info I was able to come up with -
> > http://fpaste.org/9GO6/ (bt)
> > http://fpaste.org/7gkH/ ('thread apply all bt)
> > 
> > * After the crash
> > (gdb) p mon->msg
> > $1 = (qemuMonitorMessagePtr) 0x0
> > 
> > 
> > nibbler:~ # libvirtd --version
> > libvirtd (libvirt) 0.8.0
> > 
> > 
> > Please let me know if there is any other information you need.
> > Stephen
> 
> Thanks for the report.  To be perfectly honest, I can't see how what
> happened could happen :).  But I'll take a closer look at it and see
> if I can reproduce and see what is going on with it.

  Seems that virt-manager polls the status of the domain(s) in parallel
and somehow the processing of the (unrelated) 'info balloon' call
lead to some corruption of the monitor queue.
  I would guess that snapshot-create forgets to lock something around
the monitor leading to a corruption of the monitor message queue
handling. but analyzing precisely the bug is gonna be painful as for all
threaded debugging, maybe run with full trace enabled and wtach
carefully all the locking output for the 2 commands.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]