[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] seg fault when running snapshot-create



On Wed, Apr 21, 2010 at 05:16:21PM -0400, Chris Lalancette wrote:
> On 04/21/2010 04:34 PM, Stephen Shaw wrote:
> > I'm getting a seg fault when running virsh snapshot-create 1, but only
> > when virt-manager is open and connected.
> > 
> > Here is some of the debug info I was able to come up with -
> > http://fpaste.org/9GO6/ (bt)
> > http://fpaste.org/7gkH/ ('thread apply all bt)
> > 
> > * After the crash
> > (gdb) p mon->msg
> > $1 = (qemuMonitorMessagePtr) 0x0
> > 
> > 
> > nibbler:~ # libvirtd --version
> > libvirtd (libvirt) 0.8.0
> > 
> > 
> > Please let me know if there is any other information you need.
> > Stephen
> 
> Thanks for the report.  To be perfectly honest, I can't see how what
> happened could happen :).  But I'll take a closer look at it and see
> if I can reproduce and see what is going on with it.

I see thread locking problems in the code

 - qemuDomainSnapshotCreateXML() is calling monitor commands, but has
   not run  qemuDomainObjBeginJobWithDriver() to ensure exclusive
   access to the monitor

 - qemuDomainSnapshotDiscard has same problem


Daniel
-- 
|: Red Hat, Engineering, London    -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org -o- http://virt-manager.org -o- http://deltacloud.org :|
|: http://autobuild.org        -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]