[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] default storage pool will not start



On 07/31/2010 10:06 PM, Albert Hopkins wrote:
<snip>
If I simply "touch" the file, then the pool starts.  But I don't want it
around.  No other vm's reference this file.  I've tried deleting and
re-creating the pool.  I've tried removing all the files in the pool,
removing the directory, mkdir'ing the directory and then re-creating the
pool, but it still will not start without that file.  I've
grepped /etc/libvirt for the existence of that filename but it doesn't
exist.

For the life of me I can't figure out where libvirt is getting this
information from and why it thinks it needs this file.

Hi Albert,

No worries. As a start, so we have some idea of your set up and what might be happening:

 + Which Linux distribution (and version) is this happening on?
 + Which version(s) of libvirt is installed?

If you're running on Fedora or RHEL, can you please do this and include the output in your reply?

  $ sudo ls -laR /etc/libvirt /var/lib/libvirt/

On (recent) Fedora or RHEL, that will generally show the main files of interest, so help reduce the back-and-forth emailing. :)

Also, is there a "default.xml" anywhere on your system?

  $ sudo locate default.xml | grep virt
  /etc/libvirt/storage/default.xml
  /etc/libvirt/storage/autostart/default.xml
$ sudo ls -la /etc/libvirt/storage/default.xml /etc/libvirt/storage/autostart/default.xml lrwxrwxrwx 1 root root 32 Jun 14 20:31 /etc/libvirt/storage/autostart/default.xml -> /etc/libvirt/storage/default.xml
  -rw------- 1 root root 378 Jun 14 20:31 /etc/libvirt/storage/default.xml
  $

???

(Btw, the "sudo" is important for the "locate" command. It won't otherwise display files that are only accessible to the root user, thereby missing out on many libvirt ones.)

Regards and best wishes,

Justin Clift




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]