[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] cygwin: #include netinet/inet.h -- needed only on cygwin



On 08/17/2010 06:43 PM, Stefan Berger wrote:
>> I could not reproduce the failure with the latest cygwin:
>> cygwin               1.7.6-1        OK
>> libsasl2-devel       2.1.23-1       OK
>> libxml2-devel        2.7.7-1        OK
>> sunrpc               4.0-3          OK
>>
>> What versions do you have installed?  (Not sure if I have any other
>> relevant installed packages that I didn't list here).
> 
> I had done updates just yesterday... Now I did a reinstall on the sunrpc 
> 4.0-3 I already had and the rpc/types.h changed and it does now have the 
> include of netinet/in.h as well. This of course makes the patch 
> unnecessary.

Ouch - that's a cygwin packaging bug.  Two different packages providing
the same headers is a recipe for disaster, since it then depends on
which order you install the various packages.  I've reported it
upstream: http://cygwin.com/ml/cygwin-apps/2010-08/msg00151.html

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]