[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] "virsh setvcpus" does not work.



On 12/06/2010 01:14 AM, Ken'ichi Ohmichi wrote:

Hi, and sorry for the delayed response,

> 
> Hi,
> 
> I tested "virsh setvcpus" command and it did not work like the following:
> 
>  # virsh setvcpus RHEL5.5GA_Guest.img 2
>  error: internal error unable to execute QEMU command 'cpu_set': The command cpu_set has not been ound

qemu vcpu hot-plugging has been a sore spot for some time now.  My
understanding is that an early implementation used to be upstream, but
it was buggy, so current upstream does not support it.  RHEL has taken
some efforts to provide vcpu hot-plugging beyond what upstream supports,
but it is still a work in progress, and I haven't personally tested RHEL
6.0 to see how well it does (most of my vcpu hot-plug testing was done
for RHEL 5.x with xen).

>  
>  #
> 
> Has this problem been fixed already on upstream ?
> 
> o Test environment
>   Host OS: RHEL6.0 (x86_64)
>     qemu-kvm: 0.12.1.2-2.113.el6
>     libvirt : 0.8.1-27.el6

https://bugzilla.redhat.com/show_bug.cgi?id=533138 appears to be
relevant to your situation, and mentions that the issue has been
deferred to at least RHEL 6.1.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]