[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] vmware, vcenter, clusterComputeResource error.



2010/12/16 guillaume LE LOUËT <guillaume lelouet gmail com>:
> Hello dear libvirt users.
>
> I am trying to make some migration from a VMWare esx to another.
> I am using ubuntu, and the last version found (my install script is
> http://dl.dropbox.com/u/7494462/libvirt/install.sh )
>
> The configuration is the following:
> 192.168.18.5 is the first esx
> 172.28.2.7 is the vcenter. The vcenter has been added the esx and manages
> it. The DRS is activated on that vcenter.
> The esx is running one VM, created from the vcenter.
>
> Using libvirt, I can connect to the esx
> # /opt/libvirt/bin/virsh -c "esx://192.168.18.5?no_verify=1"
> Enter username for 192.168.18.5 [root]:
> Enter root's password for 192.168.18.5:
> Welcome to virsh, the virtualization interactive terminal.
>
> I cannot however connect to the esx, specifying to use the vcenter :
> # /opt/libvirt/bin/virsh -c "esx://192.168.18.5?vcenter=*&no_verify=1"
> Enter username for 192.168.18.5 [root]:
> Enter root's password for 192.168.18.5:
> Enter username for 172.28.2.7 [administrator]: administrateur
> Enter administrateur's password for 172.28.2.7:
> error: internal error Invalid lookup from 'ClusterComputeResource'
> error: failed to connect to the hypervisor

This indicates a bug in libvirt (in the ESX driver). I can reproduce
it when I add a cluster to the datacenter. It only happens when you
try to connect to an ESX server that is part of a cluster.

> I have the same error for the following commands:
> # /opt/libvirt/bin/virsh -c
> "vpx://172.28.2.7/Entropy-VMW/Demo/192.168.18.5?no_verify=1"
> # /opt/libvirt/bin/virsh -c
> "esx://192.168.18.5?vcenter=172.28.2.7&no_verify=1"
>
> I have a different error when I use bad resource names for datacenter,
> cluster :
> # /opt/libvirt/bin/virsh -c
> "vpx://172.28.2.7/badDatacenter/Demo/dsl_18.120?no_verify=1"
> error: internal error Could not find datacenter 'badDatacenter'
> # /opt/libvirt/bin/virsh -c
> "vpx://172.28.2.7/Entropy-VMW/badCluster/dsl_18.120?no_verify=1"
> error: internal error Could not find compute resource 'badCluster'
>
> My questions are : what am I missing ? What is a ClusterComputeResource ? Do
> I need to activate or configurate some tools on the vcenter ?

As said this is due to a bug in the ESX driver. Here's a patch that
fixes the problem for me:

  https://www.redhat.com/archives/libvir-list/2010-December/msg00796.html

A ClusterComputeResource is the representation of a cluster in the
vSphere API that libvirt uses to talk to an ESX or vCenter server.

Thanks for reporting this problem.

Matthias


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]