[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] fix syntax error in configure.ac



When I run configure, I receive some syntax error.

# ./configure --without-xenapi --without-xen
......
checking where to find <rpc/rpc.h>... none
checking for library containing dlopen... -ldl
./configure: line 52500: test: =: unary operator expected
./configure: line 52766: test: =: unary operator expected
checking linux/kvm.h usability... yes
checking linux/kvm.h presence... yes
......


Signed-off-by: Wen Congyang <wency cn fujitsu com>

---
 configure.ac |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/configure.ac b/configure.ac
index 51da1b0..377b9c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -430,6 +430,7 @@ old_CFLAGS="$CFLAGS"
 LIBXENSERVER_LIBS=""
 LIBXENSERVER_CFLAGS=""
 dnl search for the XenServer library
+fail=0
 if test "$with_xenapi" != "no" ; then
     if test "$with_xenapi" != "yes" && test "$with_xenapi" != "check" ; then
         LIBXENSERVER_CFLAGS="-I$with_xenapi/include"
-- 
1.7.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]