[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCHv2 00/13] IPv6 support for virtual networks using bridge driver



On 12/31/2010 06:35 AM, Laine Stump wrote:
On 12/30/2010 10:04 AM, Laine Stump wrote:
On 12/29/2010 10:05 AM, Stefan Berger wrote:
On 12/23/2010 04:16 PM, Laine Stump wrote:
I squashed in all of Eric's recommendations and pushed this entire series.

The networkApplyTest.sh of the libvirt tck test suite does not pass anymore. I assume it's due to the changes in this part of the code. I see the following change on the broadcast address of the interface:

sh ./networkApplyTest.sh --wait --verbose --force

FAIL networkxml2xmlin/tck-testnet-2.xml : ifconfig tck-testbr | grep ':10\.1\.2\.'
1c1
<           inet addr:10.1.2.1  Bcast:0.0.0.0  Mask:255.255.255.0
---
>           inet addr:10.1.2.1  Bcast:10.1.2.255  Mask:255.255.255.0

The Bcast address is now set to 0.0.0.0 and is expected to be 10.1.2.255.


Thanks for catching this, Stefan! Apparently "ip addr add" doesn't set the broadcast address unless it's specified, where the old method of using ioctls must have set it implicitly when the netmask was set.

I'll post a patch for this later today.

The fix is included in this series:

https://www.redhat.com/archives/libvir-list/2010-December/msg01075.html
I applied them locally and ran the tests successfully.

   Stefan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]