[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt: python bindings



On 02/02/2010 09:58 AM, Pierre Riteau wrote:
> On 29 janv. 2010, at 10:05, Pierre Riteau wrote:
> 
>> On 28 janv. 2010, at 19:11, Daniel P. Berrange wrote:
>>
>>> On Thu, Jan 28, 2010 at 05:52:45PM +0000, Sharadha Prabhakar (3P) wrote:
>>>> Hi,
>>>> I'm writing XenServer APIs for libvirt and trying to test it on virt-Manager.
>>>> I need to build the libvirt python bindings for that.
>>>> I tried this for libvirt.
>>>> ./configure -with-xenapi -with-python
>>>
>>> You need to use  --  not just -  with arguments, eg --with-python
>>>
>>>> make
>>>> make install
>>>>
>>>> I suppose this is supposed to build a .libs directory with libvirtmod.so in the ~/libvirt/python/
>>>> But I don't seem to have this at all after build. It was a clean build with no errors.
>>>> I need libvirtmod.so to link with virt-manager. I'm using libvirt version 0.7.4
>>>> Can anyone help me with this. Am I missing something here
>>>
>>> Also make sure you have python-devel RPM installed (or equivalent) and
>>> have not disabled shared libraries when running configure.
>>
>>
>> When python-dev is not installed, configure currently (in version 0.7.5) disables the bindings:
>>  configure: Could not find python2.5/Python.h, disabling bindings
>>  and final output says Python: no
>>
>> When --with-python is provided, shouldn't we error out instead of disabling bindings more or less silently?

Yes, that sounds like the desired behavior.

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]