[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Cannot enumerate physical devices with libvirt 0.7.6



On 02/15/2010 02:30 PM, Frédéric Grelot wrote:
The udev driver is actually fully loaded, I even entered "udevadm
monitor" in a console, and it reacted as expected when I
plugged/unplugged an usb mouse... There is nothing about it in
dmesg/boot/message.log, nor libvirt.log (I set up libvirt daemon to
log at debug level in /var/log/libvirt/libvirt.log).

Daniel was referring to the libvirt udev driver--the libvirt code that interacts with udev--not to udev itself, which is what you're testing with udevadm. In any of your logs when you have libvirt debug logging turned on, do you see the message:

Registering udev node device backend

By the way, I noticed that libvirt generates tons of "error :
qemuMonitorTextGetBlockStatsInfo:698 : invalid argument in no stats
found for device virtio-diskX" while virt-manager is running (it
stops as soon as I stop virt-manager). Is it linked with the bug I
saw on the list about libvirt taking over memory after time isn't
it?

These messages are the result of not being able to find the device, which is consistent with the other things you're seeing. These are all symptoms of the node device code not running.

Have you any other Idea?
Frederic.


----- "Daniel P. Berrange"<berrange redhat com>  a écrit :

On Fri, Feb 12, 2010 at 08:05:21PM +0100, Fr?d?ric Grelot wrote:
Hi all,

I often update my F12 box with the rawvirt repository, which
just
installed libvirt 0.7.6. Since that, I cannot enumerate physical
devices (and thus get a beautiful error when I start one of my vms
that should use a USB device).

I don't think I changed anything else on that box, and, of
course, I
already restarted the libvirt daemon.
I haven't restarted the server itself, because it is currently
used,
but I could do it if necessary...

I make good use of the qemu hypervisor, and I'm looking forward
to
solve this issue!

Frederic.

# libvirtd --version libvirtd (libvirt) 0.7.6

# virsh --version 0.7.6

# virsh nodedev-list error :Failed to count node devices error
:this function is not supported by the hypervisor:
virNodeNumOfDevices

It would appear that the udev driver failed to start - there are
probably messages in syslog about the problem


Regards, Daniel -- |: Red Hat, Engineering, London   -o-
http://people.redhat.com/berrange/ :| |: http://libvirt.org  -o-
http://virt-manager.org  -o- http://ovirt.org :| |:
http://autobuild.org       -o- http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742
7D3B 9505 :|

-- libvir-list mailing list libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]