[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Cannot enumerate physical devices with libvirt 0.7.6



> Daniel was referring to the libvirt udev driver--the libvirt code that
> 
> interacts with udev--not to udev itself, which is what you're testing
> 
> with udevadm.

Ok, sorry... At least I ensured that udev itself is on...

>  In any of your logs when you have libvirt debug logging
> turned on, do you see the message:
> 
> Registering udev node device backend

Nope, I checked in /var/log/* and libvirt.log in debug mode (which, after 1 1/2 day of "debug" activity enabled, is already 2Gb!)
There is no mention of udev. I think it means that the udev driver is not loaded in libvirt? How could enable it then? (or produce some message telling me why it is not) ?


> These messages are the result of not being able to find the device, 
> which is consistent with the other things you're seeing.  These are
> all symptoms of the node device code not running.

OK, I'll wait for your suggestions...

Frederic.


> 
> > Have you any other Idea?
> > Frederic.
> >
> >
> > ----- "Daniel P. Berrange"<berrange redhat com>  a écrit :
> >
> >> On Fri, Feb 12, 2010 at 08:05:21PM +0100, Fr?d?ric Grelot wrote:
> >>> Hi all,
> >>>
> >>> I often update my F12 box with the rawvirt repository, which
> >>> just
> >> installed libvirt 0.7.6. Since that, I cannot enumerate physical
> >> devices (and thus get a beautiful error when I start one of my vms
> >> that should use a USB device).
> >>>
> >>> I don't think I changed anything else on that box, and, of
> >>> course, I
> >> already restarted the libvirt daemon.
> >>> I haven't restarted the server itself, because it is currently
> >>> used,
> >> but I could do it if necessary...
> >>>
> >>> I make good use of the qemu hypervisor, and I'm looking forward
> >>> to
> >> solve this issue!
> >>>
> >>> Frederic.
> >>>
> >>> # libvirtd --version libvirtd (libvirt) 0.7.6
> >>>
> >>> # virsh --version 0.7.6
> >>>
> >>> # virsh nodedev-list error :Failed to count node devices error
> >>> :this function is not supported by the hypervisor:
> >> virNodeNumOfDevices
> >>
> >> It would appear that the udev driver failed to start - there are
> >> probably messages in syslog about the problem
> >>
> >>
> >> Regards, Daniel -- |: Red Hat, Engineering, London   -o-
> >> http://people.redhat.com/berrange/ :| |: http://libvirt.org  -o-
> >> http://virt-manager.org  -o- http://ovirt.org :| |:
> >> http://autobuild.org       -o- http://search.cpan.org/~danberr/ :|
> >> |: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742
> >> 7D3B 9505 :|
> >
> > -- libvir-list mailing list libvir-list redhat com
> > https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]