[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/4] maint: start factoring bootstrap



According to Eric Blake on 2/22/2010 5:01 PM:
> Borrow ideas from gnulib/build-aux/bootstrap, in order to factor the
> specifics of libvirt into bootstrap.conf, while allowing future
> upgrades of bootstrap to happen with less effort.
> 
> * bootstrap (gnulib_tool): Update invocation to be closer to
> gnulib's version.  Move libvirt specifics...
> * bootstrap.conf: ...into new file.
...
> +# Build prerequisites
> +buildreq="\
> +autoconf   2.59
> +automake   1.9.6
> +autopoint  -
> +gettext    -
> +git        1.6.4
> +gzip       -
> +libtool    -
> +perl       5.5
> +rsync      -
> +tar        -

I don't have a RHEL 5 installation handy; are all of these prerequisites
reasonable, or is git 1.6.4 a bit strong of a pre-req?  If the latter,
then I can further patch gnulib's bootstrap to fall back gracefully to a
use of the older 'git clone --reference' instead of 'git submodule update
--init --reference'.  Are there any other tools that we should be adding
into the prereq list, now that gnulib's bootstrap does a good job of
aborting early if a development tool is insufficient for building from a
git snapshot?

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]