[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/4] maint: import modern bootstrap



On Wed, Feb 24, 2010 at 10:19:48AM +0100, Daniel Veillard wrote:
> On Mon, Feb 22, 2010 at 05:01:33PM -0700, Eric Blake wrote:
> > Note that this commit mirrors the latest upstream gnulib, but does NOT
> > update our gnulib checkout to the latest, so our version of bootstrap
> > is now newer than .gnulib/build-aux/bootstrap.
> > 
> > This also fixes a bug in the .pot files, regarding the copyright holder.
> > 
> > * bootstrap: Update to version in .gnulib/build-aux.
> > * bootstrap.conf (MSGID_BUGS_ADDRESS, COPYRIGHT_HOLDER, SKIP_PO)
> > (gnulib_mk, ACLOCAL, bootstrap_epilogue): Provide overrides.
> > * autogen.sh (autoreconf): Avoid redundant autoreconf if bootstrap
> > was run.
> > * po/Makevars: Delete, now that bootstrap creates it.
> 
>   This seems to break for me. po/Makevars.template doesn't define
> top_builddir , but that's needed in a few places in po/Makefile.in.in
> and as a result I end up with
> 
> make[2]: Entering directory `/u/veillard/libvirt/po'
> make[2]: *** No rule to make target `/config.status', needed by
> `Makefile'.  Stop.
> 
> when trying to build the normal way (./autogen.sh --system ; make)

  explicitely running ./bootstrap seems to have solved the problem for me

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]