[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt 0.7.5 vs qemu 0.12.1 imcompatability?



On Wednesday 06 January 2010 17:11:17 Tom Hughes wrote:
> On 06/01/10 15:53, Daniel P. Berrange wrote:
> > On Wed, Jan 06, 2010 at 03:38:29PM +0000, Tom Hughes wrote:
> >> The update from qemu 0.11.0 to qemu 0.12.1 in the virt-preview
> >> repository seems to have broken things. Starting a VM now just gives me
> >> a blank screen and a log which says:
> >>
> >> Option 'ipv4': Use 'on' or 'off'
> >> Failed to parse "yes" for "dummy.ipv4"
> >>
> >> I assume libvirt is sending a it a command on the monitor interface that
> >> it no longer understands...
> >
> > That warning message should be harmless - all my VMs show that and
> > they work ok. It is not actually something libirt sets - its a internal
> > QEMU default setting which is wrong
>
> Hmm... Well something is wrong because I just get a black screen. I
> don't even get the BIOS messages since I updated this morning.

If you start your VM with -kernel $image, there's a bug in qemu-0.12.1(.1?), 
which is fixed in 0.12.1.2. 

>
> Downgrading back to the fedora-updates version of qemu makes it work again.
>
> BTW the trigger for that warning seems to be that I have
> listen='0.0.0.0' set on the vnc adaptor to allow connections from remote
> machines, which causes libvirt to build a qemu command line with "-vnc
> 0.0.0.0:0".
>
> Tom




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]