[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Problem: cannot make libvirtd listen to TCP sockets



Hello,

I don't know if I am writing to the proper place, but I've been
struggling quite a long time with connecting to libvirtd. Any
information would help.

My goal is to start remote tcp connection (afterwards - tls, but
later) and connect to the libvirtd.
http://libvirt.org/uri.html#URI_remote

There are some nitoces when starting libvirtd:
-~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~-
xen:/usr/local/etc# libvirtd
17:53:42.153: error : virRun:847 : internal error '/sbin/iptables
--table filter --insert FORWARD --destination
192.168.122.0/255.255.255.0 --out-interface virbr0 --match state
--state ESTABLISHED,RELATED --jump ACCEPT' exited with non-zero status
1 and signal 0: iptables: No chain/target/match by that name

17:53:42.153: error : networkAddMasqueradingIptablesRules:615 : failed
to add iptables rule to allow forwarding to 'virbr0': Invalid argument
17:53:42.354: warning : qemudStartup:1067 : Unable to create cgroup
for driver: No such device or address
17:53:42.372: warning : lxcStartup:1755 : Unable to create cgroup for
driver: No such device or address
17:53:43.259: warning : qemudDispatchSignalEvent:385 : Shutting down on signal 2
-~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~-
libvirtd keeps running, however it does not open ANY new ports to
listening state. Extract from /usr/local/etc/libvirt/libvirtd.conf :
(full conf here: http://pastebin.com/f6e0f572)
listen_tls = 1
listen_tcp = 1

/usr/local/var/log/libvirt has 3 empty directories: {lxc,qemu,uml}, so
nothing logged.

xen:/# virsh list
shows my current running domains, so looks like libvirt is fine.

I have compiled XEN and libvirt from source (0.7.4, then upgraded
0.7.5, got same errors on both versions).

Additional information:
I am running three guest domains, all bridged to eth0 (peth0 ethernet
card -> eth0 bridge -> vifs), from xend-config.sxp:
(network-script network-bridge)

Debian lenny
Linux xen 2.6.18.8-xen0 #1 SMP Fri Nov 27 18:17:01 EET 2009 x86_64 GNU/Linux
(here is kernel config: http://pastebin.com/f393c78f0)
Note: I compiled iptables as a module manually, however without IMQ
support, since it failed to compile.

I have installed Xen 3.4.2, however virsh thinks it's 3.4.0
-~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~-
virsh # version
Compiled against library: libvir 0.7.5
Using library: libvir 0.7.5
Using API: Xen 3.0.1
Running hypervisor: Xen 3.4.0
-~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~--~*~-

Any suggestions how to properly start libvirtd, pointers to other
related mailing-lists or forums are very welcome.

Thank you!

Motiejus Jakštys


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]