[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] 0.7.5 errors in configure script



On Mon, Jan 18, 2010 at 05:04:26PM +0200, Avi Weit wrote:
> 
> Hi,
> 
> I am using Ubuntu 9.10 and downloaded and extracted libvirt.0.7.5. I have
> issued:
> ./configure --prefix=$HOME/usr --without-xen
> 
> but I get: You must install device-mapper-devel/libdevmapper >= 1.0.0 to
> compile libvirt
> 
> Below is a snippet of the final configure output:
> 
> checking for showmount... no
> checking for pvcreate... no
> checking for vgcreate... no
> checking for lvcreate... no
> checking for pvremove... no
> checking for vgremove... no
> checking for lvremove... no
> checking for vgchange... no
> checking for vgscan... no
> checking for pvs... no
> checking for vgs... no
> checking for lvs... no
> checking for iscsiadm... no
> checking for DEVMAPPER... no
> checking libdevmapper.h usability... no
> checking libdevmapper.h presence... no
> checking for libdevmapper.h... no
> checking for dm_task_run in -ldevmapper... no
> configure: error: You must install device-mapper-devel/libdevmapper >=
> 1.0.0 to compile libvirt
> 
> /dev/mapper exists on the system.

That is a device file created by the kernel/udev. 

What libvirt wants is the  device mapper library, ie libdevmapper.so
typically provided by  a device-mapper-devel/libdevmapper package, or
equivalent for your distro

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]