[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] 0.7.5 errors in configure script



2010/1/18 Frédéric Grelot <fredericg_99 yahoo fr>:
>
>> checking for dm_task_run in -ldevmapper... no
>> configure: error: You must install device-mapper-devel/libdevmapper
>> >=
>> 1.0.0 to compile libvirt
>>
>> /dev/mapper exists on the system.
>>
>
> You need the *-devel version of those packages (they provide include files in particular).
> I think it is something like libdevmapper-devel.
> Note that the "dev" stands for "device", while the "devel" stands for "development files".
>
> You may get few other errors like this one, don't forget to install *-devel versions of the packages that they complain about.
>
>
> Frederic.
>

On Fedora development packages end in -devel. On Debian/Ubuntu
development packages end in -dev. The necessary package for Ubuntu is
called:

  libdevmapper-dev

Matthias


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]